6507: Maximum users exceeded.

May 12, 2014 | KB: 90100
Laserfiche 6, Plus 6, WebLink 6

Cause

There are a number of causes for this particular error and they are listed as follows:

  • The number of users that are logged into the Laserfiche Server has reached the maximum licensed amount.
  • Weblink may be trying to access a Laserfiche Server that does not have any available Retrieval (read-only) licenses.
  • The number of Laserfiche Clients and/or Viewers installed on your network does not match the licensing on your Laserfiche Server.

Resolution

If you receive this message and you have already performed the workarounds described below, then all available licenses on the Laserfiche Server are being used. If this is the case, then you should make arrangements to increase the licensing on the Laserfiche Server. Contact your Laserfiche administrator. Your Laserfiche administrator can make arrangements with your certified Laserfiche dealer to increase the licensing on the Laserfiche Server.

Workaround

The following list describes some troubleshooting steps which may provide a workaround or resolve this issue:

  • Please wait until another user logs out of a Laserfiche database. After doing so, try logging into the database.
  • Use the Laserfiche Administration Utility (Laserfiche version 4 and 5) or the Laserfiche Administration Console (Laserfiche version 6) to manually log out any undesired connections. After doing so, try logging into the database.
  • Make sure that the number of Laserfiche Clients and Viewers workstations do not exceed the Laserfiche Server licensing. The type of Laserfiche client installed can be identified from the main splash screen that appears when the product is loaded on the workstation.

Workaround (WebLink)

There are three basic types of workarounds that you can perform when this error is generated for WebLink. You can either limit the amount of time that a WebLink user can remain inactive before being logged out, you can configure Laserfiche WebLink to use any available license on the Laserfiche Server, or you can increase the licensing on your Laserfiche Server. The first two workarounds are discussed in this section. If you would like to increase the licensing on your Laserfiche Server, then you should contact your Laserfiche administrator or your certified Laserfiche dealer.

Place Time Limits on WebLink Sessions

This workaround allows you to limit the amount of time that a WebLink user can remain inactive before being logged out of the database.

  1. Load Internet Information Services. IIS can be found under Administrative Tools in the Control Panel.
  2. Browse through the tree until the WebLink virtual directory is selected.
  3. View the properties for the WebLink virtual directory. This can be performed by selecting Properties from the Action menu.
  4. From the Virtual Directory tab, click Configuration to open the Application Configuration dialog box.
  5. Click the Options tab.
  6. Under the Session timeout option, set the amount of time (in minutes) that a WebLink user can remain inactive before being logged out of the database.
  7. Click OK to close the Application Configuration dialog box.
  8. Click OK to save your changes to the WebLink virtual directory.

Note: After a Laserfiche WebLink user has been timed out of his/her current session, then the user will not use an additional connection until he/she performs an action that requires information from the Laserfiche database. At which time, Laserfiche WebLink will need to log onto the Laserfiche Server. If a password has not been configured for the database configuration being used, then the user will be prompted for a user name and password. After specifying this information, the requested action will proceed as normal.

Note: Once a user is logged out of the database, his\her connection is then available for use by any Laserfiche user on the network. In addition to other potential Laserfiche WebLink users, this also includes Laserfiche Clients and/or Viewers (depending on the type of license that was freed up).

Use Any Available License

The licensing on the Laserfiche Server may not have sufficient Retrieval licenses for the number of concurrent WebLink users. If this is the case, then you can workaround this issue by allowing Laserfiche WebLink to use Full Client licenses. This can be performed by modifying the LFWebLink.INI file, which can be found in the C:\WINNT folder on the computer hosting Laserfiche WebLink. Add the following line to the [Options] section:

LegacyLogin=l

Note: The Laserfiche Weblink Server service must be restarted after applying this change.

More Information

One reason why your Laserfiche Server licensing is being exceeded are ghost connections. A ghost connection is a connection that was established to the Laserfiche Server, but was never closed. This typically happens when a Laserfiche Client closes down unexpectedly. The connection established by the user is not disconnected from the Laserfiche Server and thus an extra license is being used on your Laserfiche Server. If you suspect that this issue is affecting your Laserfiche installation, then you should upgrade Laserfiche to version 6.11 or higher. Laserfiche version 6.11 or higher does not suffer from this issue.

More Information (WebLink)

By default, each user that connects through Laserfiche WebLink will use a Retrieval (read-only) license. This prevents the more valued Full Client (read\write) licenses from being used by users that only need read-only access to a Laserfiche database. Although you can configure WebLink to use both Retrieval and Full Client licenses, we highly recommend that you increase the number of Retrieval licenses on your Laserfiche Server. Otherwise, you may use up licensing that otherwise would have been reserved for Laserfiche Client workstations.