Viewing documents in Public Portal/WebLink may show a white grid across every page

May 29, 2025 | KB: 1014562
WebLink, Public Portal

Summary

When viewing documents in Laserfiche Cloud Public Portal or self-hosted Laserfiche WebLink, the images may display improperly, with a white grid appearing over the pages.

Cause

The issue occurs when the web browser's zoom level is set below 100%.

Resolution

There is a temporary hotfix available for self-hosted Laserfiche WebLink 11 Update 4 (11.0.2411.10) in the form of the following updated file:

  • main.js (modified May 8, 2025)

To update self-hosted Laserfiche WebLink 11 Update 4

  1. Click the following link to download a file update for Laserfiche WebLink 11 update 4 (11.0.2411.10):

    KB1014562.zip

  2. Create a backup of the original main.js located at C:\Program Files\Laserfiche\WebLink\WebLink\Web Files\app\dist\doc-viewer\main.js. Place the backup in another location.
  3. Extract and place the updated main.js file into the C:\Program Files\Laserfiche\WebLink\WebLink\Web Files\app\dist\doc-viewer folder, replacing the original file with the new file. Do not rename or leave the original file behind.

    Note: If you are not using the default "WebLink" web application and your "Web Files" folder is in a different location than the default "C:\Program Files\Laserfiche\WebLink\WebLink\Web Files\" path, then replace the main.js file under the actual path used by your web application.

  4. Recycle the WebLinkAppPool in IIS Manager.
  5. Users must clear their web browser cache or perform a hard page refresh to see the fix.

Workaround

The workaround is to change browser zoom to 100%, and then use the Laserfiche WebLink/Public Portal document viewer's zoom controls to adjust the display as needed.