"An error occurred while receiving the HTTP response to https://activation.laserfiche.com/IActivationService.svc." Error Message Occurs When Opening the Activation Tool.

April 1, 2025 | KB: 1014471
Laserfiche 11

Summary

When running the activation tool to manually activate or deactivate a self-hosted Laserfiche application, you may receive the following error message:

    An error occurred while receiving the HTTP response to https://activation.laserfiche.com/IActivationService.svc. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down). See server logs for more details.

Cause

One potential cause of the above error is due to the Activation Tool attempting to use a no longer supported cryptographic protocol for network communications.

Workaround

Modify the Activation Tool's configuration file (ActivationToolNet4.exe.config) to force the application to use strong cryptography.

  1. Browse to the location of the Activation Tool. If you are using the version installed with Laserfiche Directory Server, the default location is C:\Program Files\Laserfiche\Directory Server.
  2. Use a text editor to open ActivationToolNet4.exe.config.
  3. Insert the following <runtime> block before the closing </configuration> tag.
    <runtime>
      <AppContextSwitchOverrides value="Switch.System.ServiceModel.DisableUsingServicePointManagerSecurityProtocols=false;Switch.System.Net.DontEnableSchUseStrongCrypto=false"/>
    </runtime>
    

Click the following link to download the Activation Tool with the configuration file is already updated:

ActivationTool.zip

Related Links

Microsoft Documentation Transport Layer Security (TLS) best practices with the .NET Framework