Summary
When running the activation tool to manually activate or deactivate a self-hosted Laserfiche application, you may receive the following error message:
An error occurred while receiving the HTTP response to https://activation.laserfiche.com/IActivationService.svc. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down). See server logs for more details.
Cause
One potential cause of the above error is due to the Activation Tool attempting to use a no longer supported cryptographic protocol for network communications.
Workaround
Modify the Activation Tool's configuration file (ActivationToolNet4.exe.config) to force the application to use strong cryptography.
<runtime> <AppContextSwitchOverrides value="Switch.System.ServiceModel.DisableUsingServicePointManagerSecurityProtocols=false;Switch.System.Net.DontEnableSchUseStrongCrypto=false"/> </runtime>
Click the following link to download the Activation Tool with the configuration file is already updated:
Additional Information
Laserfiche Plus 8.1 includes a version of the Activation Tool that does not support the configuration file workaround. To activate Laserfiche Plus, use the link provided in the workaround to download a current version of the Activation Tool. Open the Activation Tool to activate your Laserfiche Plus installation and place the generated license file in your Laserfiche Plus installation folder.
Related Links
Microsoft Documentation Transport Layer Security (TLS) best practices with the .NET Framework