Summary
When printing documents to Laserfiche Snapshot, the print status may show the document is in the queue for a long period of time.
Cause
An antivirus application on the computer could be interacting with the Windows print spooler and causing a delay.
Workaround
Add the Windows print spooler (spoolsv.exe) executable to the the respective antivirus application's exemption/exclusion list.
See the following default path for the executable: