When Launching the Laserfiche Office Integration, You May Receive the Following Error Message: "Not loaded. A runtime error occurred during the loading of the COM Add-in."

November 12, 2020 | KB: 1014224
Laserfiche

Summary

When launching the Laserfiche Office Integration, you may receive the following error message: "Not loaded. A runtime error occurred during the loading of the COM Add-in."

Cause

This problem arises after applying the patch described in 1014153 if the Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 is not already installed.
If you downloaded the Laserfiche installation package between April 11, 2020 and September 9, 2020, installing the Laserfiche Office Integration as part of the Laserfiche Windows Client will automatically apply the patch. If you installed the Laserfiche Office Integration after May 1, 2020 from Laserfiche Cloud, you may also run into this issue.

Resolution

Download and install x86 or x64 versions of Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 from Microsoft's site.

Notes

  • The Laserfiche Windows and web client installations in the Laserfiche 10.4.3 package have been updated to include a fix for this issue on September 11, 2020.
  • If you installed the Laserfiche web client 10.4.2 before September 11, 2020, please replace the "LfWebOffice104.exe" file in "\Web Files\OfficePlugin" with the copy attached to this KB article in order to have new installation use the fixed version. By default, the web client's install folder is C:\Program Files\Laserfiche\Web Access