When Using Distributed Computing Cluster, You May Receive the Following Error Message: "License error: 'Validation Error code: 'ConnectionFailed'."

April 6, 2021 | KB: 1014164
Laserfiche Directory Server 10.4.3, Distributed Computer Cluster

Summary

You may find that after a reboot, Distributed Computing Cluster fails to validate its license against Laserfiche Directory Server and you may see the following error message: "The operation could not have been completed because the Distributed Computing Cluster is not licensed. License error: 'Validation Error code: 'ConnectionFailed'." Additionally, you may find that the only way for the Distributed Computing Cluster to function again is by generating a new Distributed Computing Cluster license. An example of when you encounter this problem is that when running a scheduled OCR activity in Laserfiche Workflow 10.4 you may receive the aforementioned error message.

Cause

Distributed Computing Cluster may be unable to properly communicate with the Laserfiche Directory Server, which leads to a validation error. One potential cause is that if Distributed Computing Cluster and Laserfiche Directory Server are on the same computer and you restart that computer, Laserfiche Directory Server may not be fully started when Distributed Computing Cluster attempts to connect to it.

Resolution

There is a hotfix available for the Distributed Computing Cluster that resolves this issue. Distributed Computing Cluster will now retry connecting to Laserfiche Directory Server.

Click the following link to download the hotfix:

KB1014164.zip

  1. Back up Laserfiche.DistributedComputingCluster.InternalCommon.dll from C:\Program Files\Laserfiche\Distributed Computing Cluster\bin to a new location.
  2. Extract the new DLL from the ZIP file and place it into C:\Program Files\Laserfiche\Distributed Computing Cluster\bin.
  3. Restart Distributed Computing Cluster.