Summary
When upgrading or installing Laserfiche products released after February 7th, 2020 on the same computer as Workflow Server 10.4, you may receive the following error message when running workflows that access the Laserfiche repository: "Could not load file or assembly 'Microsoft.Diagnostics.Tracing.EventSource, Version=1.1.28.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified." For example, you may receive this error when using the "Search" or "Find Entry" activities.
Cause
If you installed or upgraded a Laserfiche product using an installation package created after February 7th, 2020, you may need to reinstall with an updated installation package. The previous installation package included an incompatibility with other Laserfiche client applications.
Resolution
Download the .zip archive (KB1014128.zip), unpack the file, and place in the Workflow installation folder (C:\Program Files\Laserfiche\Laserfiche Workflow 10.4 by default.)