When Signing in to Laserfiche Web Client Through Laserfiche Directory Server, You May See the Following Error Message: "Error 405- HTTP verb used to access this page is not allowed."

March 27, 2020 | KB: 1014090
Laserfiche Cloud

Summary

While attempting to sign in to Laserfiche web client through Laserfiche Directory Server 10.4.2, you may see the following error message: "Error 405- HTTP verb used to access this page is not allowed. The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access." You may be able to use Laserfiche Directory Server to successfully authenticate other Laserfiche client applications.

Cause

The wrong web client host URL may be specified in the Laserfiche web client configuration page. If the web client host URL configuration is invalid, the Laserfiche web client page cannot be accessed.

Resolution

Open the web client configuration page and update the web client host URL.

Update the web client host URL:

  1. Go to http://machinename.sampledomain.com/configuration to check for typos in the web client host URL.
  2. Under Configuration, click Services.
  3. Under General Services in Laserfiche Web Client Host URL, enter the desired web client host URL, which might look similar to the following: http://machinename.sampledomain.com/laserfiche.
  4. At the bottom, click Save.

If you cannot access the web client configuration page, you can manually edit the web access configuration file:

  1. Open the following file in a text editor: C:\Program Files\Laserfiche\Web Access\Web Files\Config\WebAccessConfig.xml
  2. Modify the value of the BaseUrl element.