While using Laserfiche Directory Server to import thousands of users, the CSV import may fail and you may get an error stating "Can't add users to group."

December 12, 2019 | KB: 1014077
Directory Server 10.4

Summary

When importing thousands of users via a CSV file on the Laserfiche Directory Server, the import may fail due to the large number of entries. You may get an error stating: "Can't add users to group."

Cause

The large number of users cannot be added due to the maximum request length.

Resolution

The default entry limit needs to be overridden in the web configuration. To do so, follow the steps below:

  1. Go to the web.config for the Laserfiche Directory Server administration site. The default installation path is: C:\Program Files\Laserfiche\Directory Server\Web\LFDS\web.config
  2. Back up the web.config.
  3. Open the web.config in a text editor and within the system.web block, locate the the httpRuntime element. Next to the targetFramework, add a second element: maxRequestLength. Set this element to a large value, such as 1048576. The system.web block may look similar to the following sample:
            < system.web>
            < compilation debug="true" targetFramework="4.7.2" / >
            < httpRuntime targetFramework="4.7.2" maxRequestLength="1048576" / >
            < authentication mode="Windows" / > 
            
  4. Recycle the LicenseManagerAppPool Application Pool in Internet Information Services.

The configuration change can be reverted after successful import.