When Using Laserfiche Workflow 10.2 to Invoke a Workflow on a Different Server, the Invoke Workflow Activity Runs but No Workflow is Invoked.

March 30, 2020 | KB: 1014065
Laserfiche Workflow 10.2

Summary

While using Laserfiche Workflow 10.2 you invoke a workflow on a different server by using the "Invoke Workflow" activity. The activity runs with no errors but no workflow is actually invoked.

Cause

The workflow server on one machine is not able to communicate with the workflow server of another machine. The reason may be that the Microsoft Message Queuing service (MSMQ) is blocked on one machine or the other. One of the reasons for this is that there may a be a firewall blocking the ports on which MSMQ is running. To learn more about the ports used by MSMQ, see the following Knowledge Base article: TCP ports, UDP ports, and RPC ports that are used by Message Queuing.

Resolution

Allow communications through TCP port 1801 for MSMQ through a firewall. For information on configuring a firewall for MSMQ access, see How To Configure a Firewall for MSMQ Access.