ODBC lookups from Microsoft Excel fail in Quick Fields and Quick Fields Scanning

October 13, 2020 | KB: 1013914
Quick Fields

Summary

When using an ODBC lookup configured to retrieve information from an Excel file in Quick Fields or Quick Fields Scanning, you may receive the following error: An error occurred accessing Excel. Please make sure the Excel file used is closed.

Cause

The October 2017 Microsoft Office security updates (KB4041676 and/or KB4041681) broke a JET provider driver, and consequently, the ability for Quick Fields and Quick Fields Scanning to look up information in a Microsoft Excel file using an ODBC connection with the specific JET driver.

Resolution

Microsoft has released security patches to fix this issue. See the Microsoft Developer Blog for more information. We recommend switching ODBC to use the ACE provider for lookup processes using Microsoft Excel since the JET provider has been deprecated by Microsoft.