Digital Signatures are Not Working in Laserfiche Windows Client and You May Receive the Following Error Message: "No usable certificates found. To import a certificate, use the Certificate Manager or contact your system administrator."

May 11, 2020 | KB: 1013913
Laserfiche Client 10

Summary

You may find that you cannot add a digital signature to a document in Laserfiche Windows client. You may also receive the following message within the Select Certificate dialog box: "No usable certificates found. To import a certificate, use the Certificate Manager or contact your system administrator."

Cause

One potential cause is that there is no valid certificate under the current user's personal certificate store.

Resolution

Verify that there is a valid certificate in the user's personal certificate store. Ensure that the certificate is installed with the private key.