A "The remote server returned an error: (404) Not Found" Error Occurs When Running Workflows With Activities that Connect to Laserfiche Forms 10.2.1.

May 23, 2017 | KB: 1013863
Forms 10.1.1, Workflow 10.2

Summary

Workflows with Laserfiche Forms activities may be unable to connect to a Laserfiche Forms 10.2.1 server with the following error:

    The remote server returned an error: (404) Not Found

You may see this error with the following activities:

  • Invoke Business Process
  • Retrieve Business Process Variables
  • Set Business Process Variables

Cause

This issue can occur after upgrading to Laserfiche Forms 10.2.1 if the existing Laserfiche Forms installation is using HTTP communication. The default configuration for a new Laserfiche Forms installation expects secure connections and the upgrade process resets to this default configuration instead of retaining the existing configuration.

Workaround

Open the Laserfiche Forms Configuration page and reset the Use SSL connection option on the Forms Server page.

  1. Open the Forms Configuration page through the Start menu or by typing the URL in your browser address bar. The default URL for the Configuration page is http://machinename/FormsConfig, where machinename is the name of the server where Forms is installed.
  2. Click the Forms Server tab.
  3. Select and clear the Use SSL connection checkbox and save.