An "Exception: System.Web.HttpException (0x80004005): There was no channel actively listening at 'https://SampleFormsServer/forms/api/BusinessProcess/Listing'" Error Occurs When Configuring Forms with Workflow over SSL.

May 24, 2016 | KB: 1013764
Forms 10, Workflow 10

Summary

In certain upgrade scenarios, Workflow may be unable to connect to Forms 10 when IIS is configured to redirect web traffic from HTTP to HTTPS.

The Windows Event Log may contain an entry similar to the following:

    Exception: System.Web.HttpException (0x80004005): There was no channel actively listening at 'https://SampleFormsServer/forms/api/BusinessProcess/Listing'. This is often caused by an incorrect address URI. Ensure that the address to which the message is sent matches an address on which a service is listening.

Cause

The Forms API web.config may not be properly configured for SSL. In certain installation situations, the configuration file may have been reset to the default configuration.

Workaround

Use the Forms Configuration site to reenable the Use SSL connection option.

  1. Open the Forms Configuration site and view the Forms Server tab.
  2. Make sure the Use SSL connection option is enabled. If it is already enabled, clear the checkbox and reselect the checkbox.
  3. Click Save on the page.