Summary
In certain upgrade scenarios, Workflow may be unable to connect to Forms 10 when IIS is configured to redirect web traffic from HTTP to HTTPS.
The Windows Event Log may contain an entry similar to the following:
Exception: System.Web.HttpException (0x80004005): There was no channel actively listening at 'https://SampleFormsServer/forms/api/BusinessProcess/Listing'. This is often caused by an incorrect address URI. Ensure that the address to which the message is sent matches an address on which a service is listening.
Cause
The Forms API web.config may not be properly configured for SSL. In certain installation situations, the configuration file may have been reset to the default configuration.
Workaround
Use the Forms Configuration site to reenable the Use SSL connection option.