Product Activation May Be Unsuccessful on Windows 8.1 or Windows Server 2012 R2 and Later.

September 18, 2020 | KB: 1013668
Laserfiche 8, Laserfiche 9

Summary

Product activation may be unsuccessful on new computers with Windows 8.1, Windows Server 2012 R2, and later.

For example, requesting a primary license in Laserfiche Directory Server may display the following error message:

    Activation was not successful: Could not establish trust relationship for the SSL/TLS secure channel with authority 'activation.laserfiche.com'. (LFDS10)(LMO0)

Cause

Secure communication to the Laserfiche activation site occurs over port 443 using HTTPS. If the port is open and the affected machine can connect to the Laserfiche activation server, then the above error may indicate a certificate verification issue.

The Laserfiche activation site is signed with a certificate from Let's Encrypt. Unlike previous versions of Windows, Windows 8.1 and Windows Server 2012 R2 no longer include the necessary Let's Encrypt certificate in the machine's trusted root certification authorities by default.

Resolution

Download the necessary root authority certificate from Let's Encrypt and install it to all necessary computers.

Visit https://letsencrypt.org/certificates and download a copy of the Let's Encrypt Authority X3 certificate.

Use Active Directory group policy or the Certificates MMC snap-in to add the certificate to the Trusted Root Certification Authorities of every machine that will connect to the Laserfiche activation server.

Note: Make sure that the certificate is installed to the local machine certificate store, not the certificate store for a user account.