Summary
The Laserfiche Client search pane may not display certain user interface elements in the Text search type. Selecting the AND, OR, NOT, or WITHIN operators does not display the additional text boxes.
Cause
This issue can occur when the VBScript engine is not correctly registered. This issue can occur when certain antivirus software change the registry to point to a custom antivirus scanner DLL file. Upon uninstalling the antivirus software, the installer does not reset the registry back to the default value.
Workaround
Open the Windows Registry editor and verify that the value of HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32 is pointing to the Windows provided vbscript.dll. On 64-bit Windows, make sure to also check the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32 key as well.
If the registry key is pointing to a non-existent DLL file, either manually modify the registry value to point to the correct location of vbscript.dll or use the regsvr32 command to re-register vscript.dll.