A "The session has been reset by the server. [0637-WF1]" Error Occurs In The Workflow Subscriber.

March 2, 2015 | KB: 1013618
Workflow Suite 8, Workflow Suite 9

Summary

At unexpected times, the Workflow Subscriber stops responding. In the log, you see entries similar to the following:

    The session has been reset by the server. [0637-WF1]

Cause

One possible cause is that the system time of the computer hosting the Subscriber is out-of-sync with the rest of the domain. When the system time deviation exceeds a certain limit, Windows resets the system time to match the correct time. When the reset happens, it causes the Workflow server to also reset. In order for Workflow to function, the system time must be accurate.