An "Access denied. [9013]" Error Occurs When Overwriting An Existing Electronic Document.

February 9, 2015 | KB: 1013603
Laserfiche 9

Summary

See the following scenario:

  1. Log in with an account that does not have the Delete Entry or Delete Document Pages entry access rights on an electronic document.
  2. The account does have the Modify Contents entry access right on the electronic document.
  3. Import an electronic file with the same name into the folder with the electronic document from step 1.
  4. Select the option to overwrite the existing document with the new file.
  5. You receive an "Access denied" error message, but the electronic file associated with the Laserfiche document is successfully overwritten.

Cause

When replacing the electronic file, the Laserfiche Client first attempts to delete the existing text pages in the document before generating new text pages. Due to the lack of delete rights, the Laserfiche Client receives the access denied message.

Laserfiche will still generate text pages successfully.

In the situation where the existing document has more text pages than generated from the new electronic file, the preexisting pages will be retained as empty pages in the document.