Summary
When a workflow reassigns the template on a document with the Assign Field Values activity, the existing assigned fields may be set as independent fields on the document even though the Remove fields from unassigned templates option is enabled on the activity.
Cause
This issue can occur when the Workflow user does not have sufficient rights on the fields already set on the document. When the workflow reassigns the new template, the workflow cannot remove the already assigned field values on the document.
Resolution
Verify that the Workflow user account has sufficient rights to remove the appropriate fields from a document.