A "Retrieving the COM class factory for component with CLSID {D94D3976-B933-495E-AD3E-9D6FA6CB418D} failed due to the following error: 80080005" Error Occurs In Laserfiche Scanning 9.1.1.

April 28, 2022 | KB: 1013569
Scanning 9.1.1

Summary

After installing Laserfiche 9.1.1 Service Pack 1 on a 64-bit version of Microsoft Windows, Laserfiche Scanning may display the following error message:

    Exception has been thrown by the target of an invocation.

    Retrieving the COM class factory for component with CLSID {D94D3976-B933-495E-AD3E-9D6FA6CB418D} failed due to the following error: 80080005

Cause

The upgrade process may incorrectly update certain 32-bit OCR components with the 64-bit version files.

Workaround

Manually replace the affected DLL files with the 32-bit versions.

Download the following ZIP file containing the 32-bit replacement files.

KB1013569

Extract the contents of the ZIP file to the following locations:

  • C:\Program Files (x86)\Common Files\Laserfiche\9.1\BPImageWrapper91.dll
  • C:\Program Files (x86)\Common Files\Laserfiche\Batch Processor\BPInterfacesClient.dll
  • C:\Program Files (x86)\Common Files\Laserfiche\Batch Processor\BPObjectsClient91.dll
  • C:\Program Files (x86)\Common Files\Laserfiche\Batch Processor\BPOCRClientWrapper90.dll
  • C:\Program Files (x86)\Common Files\Laserfiche\Batch Processor\BPPageFixClient91.dll
  • C:\Program Files (x86)\Common Files\Laserfiche\Batch Processor\Laserfiche.BatchProcessor.Utils.dll