A "Data source name not found and no default driver specified" Error Occurs In The Audit Trail 9.2 Configuration Wizard.

November 3, 2015 | KB: 1013568
Audit Trail 9.2

Summary

When viewing the Audit Trail 9.2 Configuration Wizard, the page displays the following error on the SQL Database configuration page:

    ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Cause

Laserfiche Audit Trail 9.2 is not fully compatible with the Microsoft SQL Server 2008 R2 Native Client.

Resolution

This issue is resolved in Laserfiche 9.2. Service Pack 1 and later. Please update to the latest version of Audit Trail 9.2.

Workaround

Manually install the Microsoft SQL Server 2005 Native Client. The Laserfiche Avante and Laserfiche Rio installation packages include an installation for the Microsoft SQL Server 2005 Native Client.

On the Laserfiche Avante or Laserfiche Rio installation package, browse to the en\Support folder, and run one of the following files:

  • 32-bit Windows: sqlncli.msi
  • 64-bit Windows: sqlncli_x64.msi

On a 32-bit version of Windows, use sqlncli.msi. On a 64-bit version of Windows, use sqlncli_x64.msi.

Related Links

1013588 List of Changes for Laserfiche 9.2 Service Pack 1.