A "Could not load file or assembly 'Laserfiche.DistributedProcessing.Common'" Error Occurs When Publishing A Workflow With A Schedule OCR Activity.

May 2, 2014 | KB: 1013478
Workflow Suite 9.1

Summary

When publishing a workflow that contains a Schedule OCR activity, you may receive the following error message:

    Could not load file or assembly 'Laserfiche.DistributedProcessing.Common, Version=9.1.0.0, Culture=neutral, PublicKeyToken=607dd73ee2bd1c00' or one of its dependencies. The system cannot find the file specified.

Cause

The Workflow 9.1 Designer installation does not include client dependencies for communicating with a Laserfiche Distributed Computing Cluster Scheduler. This issue can occur if the computer with the Workflow Designer does not contain another Laserfiche product that installs the necessary dependencies.

Workaround

Install a Laserfiche product that includes the necessary client dependency files for communicating with a Laserfiche Distributed Computing Cluster Scheduler. For example, installing the Laserfiche Workflow Server on the same computer will install the necessary files.