An "Error logging in. The Laserfiche client was unable to intercept the Print Screen hot key" Error Occurs When You Log In With A Second Instance Of Laserfiche Client 9.

April 22, 2022 | KB: 1013377
Laserfiche 8.3, Laserfiche 9, Laserfiche 10, Laserfiche 11

Summary

See the following scenario:

  1. Open an instance of the Laserfiche Client and log in as a user that does not have the Export feature right.
  2. Open a second instance of the Laserfiche Client and log in as a user that does not have the Export feature right.
  3. You may receive the following error: Error logging in. The Laserfiche client was unable to intercept the Print Screen hot key.

Cause

By default, the Laserfiche Client attempts to disable the Print Screen keyboard key if a user does not have the Export feature right. However, this functionality can only track one client instance.

Workaround

Add the [Settings]PrintScreenIntercept trustee attribute to control whether the Laserfiche Client will perform this check.

Use the Laserfiche Administration Console to add the [Settings]PrintScreenIntercept attribute on the desired user accounts. You can also add this attribute on the Everyone group. Set the value to No to stop the Laserfiche Client from trying to disable the Print Screen key.