The Workflow Subscriber Logs An "Insufficient resources to perform operation." Error.

August 19, 2013 | KB: 1013301
Workflow Suite 8, Workflow Suite 9

Summary

The Laserfiche Workflow Subscriber logs an "Insufficient resources to perform operation" error.

Cause

The message backlog has exceeded the storage limit set for Message Queuing. A backlog can arise in a variety of situations:

  • The Workflow Server is down.
  • There is a runaway starting rule with an infinite loop.
  • The Workflow Server is overloaded.

Workaround

A Message Queue backlog usually indicates a configuration issue. Please check your starting rules and workflows to see if you can optimize certain steps of the process. As an immediate measure, see the following workarounds. You can either choose to increase the storage limit for Message Queuing as a temporary measure, or you can delete messages in the backlog.

To increase the storage limit for Message Queuing

  1. Click Start, point to Administrative Tools, and select Computer Management.
  2. Under Services and Applications, right-click on Message Queuing and select Properties.
  3. In the Storage limits section, increase the values for Limit message storage to (KB) and Limit journal storage to (KB).

Clear out all messages in the offending queue

Warning: This procedure will clear out all backlog messages. Only use the following steps if losing the Workflow backlog is an acceptable resolution.

  1. Click Start, point to Administrative Tools, and select Computer Management.
  2. Under Services and Applications, expand Message Queuing.
  3. Select Private Queues.
  4. In the Number of Messages column, look for the problematic queue.
  5. Right-click on the queue and select Delete.