Summary
If Laserfiche Forms 9.0.1 is installed on a computer prior to Laserfiche Quick Fields, Workflow, Import Agent, or Web Access, you may be unable to properly start those programs. You may see the following message in the Windows Event Log:
Could not load file or assembly 'LfLicenseReader, Version=8.3.0.0, Culture=neutral, PublicKeyToken=607dd73ee2bd1c00' or one of its dependencies. The system cannot find the file specified.
Cause
Laserfiche Forms includes a version of LfLicenseReader that targets the .NET Framework 4 CLR, while the other programs include a version that targets the .NET Framework 2 CLR. Windows Installer may not properly install the dll in the .NET Framework 2 Global Assembly Cache (GAC) if it detects that a dll with the same assembly version is already installed in the .NET Framework 4 GAC.
Workaround 1
Work around the Windows Installer issue by first installing the appropriate programs that require the .NET Framework 2 version of the assembly.
Workaround 2
If you are comfortable with manually removing assemblies from the .NET 4 Global Assembly Cache, you can manually delete the LfLicenseReader folder from the .NET Framework 4 GAC. Use the Windows Add/Remove Programs feature to repair the affected Laserfiche program first. Then use the Windows Add/Remove Programs feature to repair Laserfiche Forms.