Summary
When upgrading from a previous version of Laserfiche 8.3 to Laserfiche 9.x, you may receive the following error message:
The older version of CombinedARP cannot be removed. Contact your technical support group.
Cause
You may receive the above error message if the upgrade process cannot locate a copy of the Laserfiche 8.3 installation (.msi files). When upgrading to Laserfiche 9, Windows Installer first checks the Windows Installer cache for copies of the Laserfiche 8.3 installation (.msi files) in order to remove old components. If it cannot locate a copy in the cache, it falls back to checking the source of the original installation package.
Workaround
Browse to the Laserfiche Client 8.3 and Laserfiche Server 8.3 Windows Installer registry entries and take note of the original install source location.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{2F2BAA27-B93C-4BE7-80EE-509F7C9E3B6C}
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{C689A98B-CFEA-40EF-BAB5-1E6D84DF075B}
Place a copy of the Laserfiche 8.3 installation (.msi files) in the original source location.
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you have a backup and understand how to restore it if a problem occurs.
Note: If InstallSource is not available (e.g., the drive is no longer available), you can modify InstallSource to point to a new location. Make sure to keep the trailing backslash character in the new value.