A "Login failed for user 'servername\accountname'" Error Occurs When Loading The Laserfiche Forms Website.

May 6, 2013 | KB: 1013244
Laserfiche Forms 9

Summary

When loading the Laserfiche Forms website, you may receive the following error message:

    Login failed for user 'servername\accountname$'.

    Cannot open database "LaserficheFormsDatabase" requested by the login. The login failed. Login failed for user 'IIS APPPOOL\FormsAppPool'.

Cause

This error can occur if the Laserfiche Forms application pool is running as an account that cannot access the Laserfiche Forms SQL database.

Resolution

Use Internet Information Services (IIS) Manager to change the identity on the FormsAppPool application pool. If the Forms SQL database is located on a different computer from Laserfiche Forms, make sure to use a domain account with rights to access that computer.

Related Links

http://www.laserfiche.com/support/webhelp/LaserficheForms/9.0/en-us/Forms/Default.htm#WindowsAuthentication.htm