When the Forms Server is Located in the DMZ, Form Submissions from External Users May Not Be Correctly Saved to Laserfiche

April 16, 2013 | KB: 1013218
Laserfiche Forms

Summary

When the Forms Server is located in the DMZ, form submissions from external users may not be correctly saved to Laserfiche. When viewed in Laserfiche, these improperly saved form submissions will appear blank but will contain process information in their metadata.

Cause

This issue occurs when users access Laserfiche Forms via a URL different from the one used locally by the machine hosting the Forms Server. When a user submits a form and Save to Laserfiche is enabled, the Forms Server takes the user's URL and passes it to the Save to Laserfiche tool that generates the submission image. If the machine does not have access to that URL, Save to Laserfiche will not be able to open the URL and will instead capture the blank webpage and save that image to the repository.

Solution

The machine hosting the Forms Server should be given access to the URL where external users access Laserfiche Forms.