Laserfiche Server May Become Unresponsive When Processing Certain Types Of Searches In Large Repositories.

March 18, 2013 | KB: 1013173
Laserfiche 8.3.1, Laserfiche 8.3.2, Laserfiche 9

Summary

In certain large repositories, Laserfiche may become unresponsive when processing search results for a large search.

Cause

The default Laserfiche search plan embeds checking access rights in the search query. Depending on your database structure, this option may result in poor search performance.

Workaround

In Laserfiche 8.3 and later, you can configure Laserfiche to use an alternate security calculation mode. Under the HKEY_LOCAL_MACHINE\Software\Laserfiche\Engine\8.0\Repositories\YourRepositoryName registry key, add a DWORD value named SearchFTSACLCheckMode and a DWORD value named SearchFieldACLCheckMode. Set the values of both DWORD values to 1 to switch to the alternate mode.

  1. On the Laserfiche Server, click Start, All Programs, Accessories, and click Command Prompt to load a command prompt.
  2. Type the following and press ENTER to load the Windows Registry Editor:

    regedit

  3. Expand HKEY_LOCAL_MACHINE.
  4. Expand SOFTWARE.
  5. Expand Laserfiche.
  6. Expand Engine.
  7. Expand 8.0.
  8. Expand Repositories.
  9. Select YourRepositoryName
  10. From the Edit menu, point to New and click DWORD Value.
  11. Name the value:

    SearchFTSACLCheckMode

  12. Set the value to 1.
  13. Repeat step 10 for:

    SearchFieldACLCheckMode

  14. Set the value to 1.