Summary
When opening an electronic document with a long name in Laserfiche Client 8.3.1, you may receive an error message in the native application stating that the file could not be found. For example, if you are opening a Microsoft Excel document, Excel will open and then you may receive an Excel message similar to the following:
'LongPathToElectronicDocument' could not be found. Check the spelling of the file name, and verify that the file location is correct.
If you are trying to open the file from your list of most recently used files, make sure that the file has not been renamed, moved, or deleted.
Cause
This issue can occur when the path to the temporary local copy of the electronic file exceeds the character limit for a Windows path. Depending on the number of exceeded characters, you may instead receive the following Laserfiche error message and the native application for the electronic document will not load:
Error creating file. [6411]
Resolution
This issue is resolved in Laserfiche 9.0.2 and later.
Workaround 1
Rename the electronic document to have a shorter name in Laserfiche.
Workaround 2
Depending on your version of Windows, the Laserfiche Client stores local copies of electronic files in either C:\Users\UserName\AppData\Local\Temp or C:\Documents and Settings\UserName\Local Settings\Temp. You can create the [Options]ElectronicFileExportPath trustee attribute to modify this location to conserve characters in the path. For example, you can set the value of the attribute to C:\LF.