Logging In Through Laserfiche Client Programs May Be Slow In Certain Network Configurations.

December 9, 2019 | KB: 1012934
Laserfiche 8, Laserfiche 9, Laserfiche 10

Summary

When logging in with a Laserfiche client application, there may be an unexpected pause before you successfully log in to the repository.

Cause

During the login process, the Laserfiche Server looks up your client host name through DNS. In certain network configurations, this process may be slow.

Workaround

Configure the Laserfiche Server to no longer do a DNS name lookup.

  1. On the Laserfiche Server computer, click Start and then click Run.
  2. In the Run dialog box, type the following and click OK to load the Windows Registry Editor:
  3. regedit

  4. Expand HKEY_LOCAL_MACHINE.
  5. Expand SOFTWARE.
  6. Expand Laserfiche.
  7. Expand Engine.
  8. Expand 8.0.
  9. Select the HttpServ key.
  10. From the Edit menu, point to New and click DWORD Value.
  11. Name the new value:
  12. ReverseNameLookup

  13. Double-click the ReverseNameLookup value you created in the previous step.
  14. Set the value to 0.
  15. Restart the Laserfiche Server.

Important: Disabling reverse lookup means that connections in the Laserfiche Administration Console and the audit log will show up as IP addresses instead of host names.