A "This application has failed to start because the application configuration is incorrect." Error Occurs When Starting the Laserfiche Client on Windows XP or Windows Server 2003.

August 7, 2014 | KB: 1012917
Laserfiche 8.2, Laserfiche 8.3

Summary

See the following scenario:

  • A computer is running Windows XP or Windows Server 2003.
  • You install Laserfiche Client 8.2 or later.
  • You install another Laserfiche 8 product.
  • You uninstall that Laserfiche 8 product.
  • You may receive the following error message when loading the Laserfiche 8 Client:
    • C:\Program Files\Laserfiche\Client 8\LF.exe

      This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

Cause

There is potential Windows Side-by-Side (WinSxS) installation issue involving LFWicUtil.dll that affects Windows XP and Windows Server 2003. The issue arises when you install a Laserfiche program that includes a later version of LFWicUtil.dll than the version used by the Laserfiche Client. If you then uninstall that Laserfiche program, the uninstallation process removes the actual DLL from the WinSxS component store, but does not remove a policy file that still points to the now deleted DLL.

Resolution

Browse to the "C:\WINDOWS\WinSxS\Policies" folder and look for folders containing LFWicUtil in the name. Delete only those folders that contain policy files pointing to non-existent versions of LFWicUtil.

See the following example using the 32-bit version of Windows XP:

  • On a computer with no Laserfiche products, you install Laserfiche Client 8.3.0.
  • The WinSxS component store will contain:
  • c:\WINDOWS\WinSxS\x86_LFWicUtil_c9173f2a5647b0d5_8.3.0.101_x-ww_82381485

    and

    C:\WINDOWS\WinSxS\x86_LFWicUtil_ca6e4d00d8aa24c2_8.2.0.5_x-ww_824f38c8

    The Policies subfolder will contain:

    c:\WINDOWS\WinSxS\Policies\x86_policy.8.2.LFWicUtil_ca6e4d00d8aa24c2_x-ww_ce6cad7c

  • Then you install Web Access 8.3.1. The WinSxS component store now contains an additional LFWicUtil (version 8.3.0.103) folder and the Policies subfolder will contain:
  • c:\WINDOWS\WinSxS\Policies\x86_policy.8.3.LFWicUtil_c9173f2a5647b0d5_x-ww_0120bf3c

  • Now you uninstall Web Access 8.3.1. The uninstallation process removes the folder containing LFWicUtil.dll (version 8.3.0.103) from C:\WINDOWS\WinSxS, but the process does not correctly remove the policy file in "c:\WINDOWS\WinSxS\Policies\x86_policy.8.3.LFWicUtil_c9173f2a5647b0d5_x-ww_0120bf3c" that points to LFWicUtil 8.3.0.103 (which no longer exists).
  • Attempting to load the Laserfiche Client now returns the error in the Summary.
  • In this sample scenario, you can manually delete that "x86_policy.8.3.LFWicUtil_c9173f2a5647b0d5_x-ww_0120bf3c" folder in the "C:\WINDOWS\WinSXS\Policies" folder.