Summary
See the following scenario:
C:\Program Files\Laserfiche\Client 8\LF.exe
This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
Cause
There is potential Windows Side-by-Side (WinSxS) installation issue involving LFWicUtil.dll that affects Windows XP and Windows Server 2003. The issue arises when you install a Laserfiche program that includes a later version of LFWicUtil.dll than the version used by the Laserfiche Client. If you then uninstall that Laserfiche program, the uninstallation process removes the actual DLL from the WinSxS component store, but does not remove a policy file that still points to the now deleted DLL.
Resolution
Browse to the "C:\WINDOWS\WinSxS\Policies" folder and look for folders containing LFWicUtil in the name. Delete only those folders that contain policy files pointing to non-existent versions of LFWicUtil.
See the following example using the 32-bit version of Windows XP:
c:\WINDOWS\WinSxS\x86_LFWicUtil_c9173f2a5647b0d5_8.3.0.101_x-ww_82381485
andC:\WINDOWS\WinSxS\x86_LFWicUtil_ca6e4d00d8aa24c2_8.2.0.5_x-ww_824f38c8
The Policies subfolder will contain:c:\WINDOWS\WinSxS\Policies\x86_policy.8.2.LFWicUtil_ca6e4d00d8aa24c2_x-ww_ce6cad7c
c:\WINDOWS\WinSxS\Policies\x86_policy.8.3.LFWicUtil_c9173f2a5647b0d5_x-ww_0120bf3c