An "Operation timed out. [784]" Error Occurs When Logging In To Laserfiche 8 Or Higher Using Windows Authentication.

February 4, 2014 | KB: 1012887
Laserfiche 8, Laserfiche 9

Summary

When logging in to your Laserfiche 8 or higher Repository through Windows Authentication, you may receive the following error message:

    Operation timed out. [784]

When you try to log in using a Laserfiche user account, the process completes successfully.

Cause

In certain network configurations, there may be communications delays. One possible scenario is if you are connected to the network over VPN from a distant location. A delay in retrieving or verifying Windows user credentials during the login process can cause the Laserfiche Client to time out while attempting to log in to the Laserfiche Server.

Workaround

You can extend the client-side login timeout for LFSO client applications by adding a registry value.

Under the HKEY_LOCAL_MACHINE\Software\Laserfiche\LFSO\version key, create a DWORD value named LoginTimeoutSeconds. Set the value of LoginTimeoutSeconds to the number of seconds to wait before timing out. The default value is 20 seconds.

Replace version with the appropriate version number for your client program in major.minor format. For example, with Laserfiche Client 9.0.x, use the HKEY_LOCAL_MACHINE\Software\Laserfiche\LFSO\9.0 key. With Laserfiche Client 8.3.x, look for the HKEY_LOCAL_MACHINE\Software\Laserfiche\LFSO\8.3 key.

Note: If you are on a 64-bit version of Windows, use the HKEY_LOCAL_MACHINE\Software\Wow6432node\Laserfiche\LFSO\version key.

Note: The LoginTimeoutSeconds registry value is available for Laserfiche Client 8.1 and later.

Note: Manually create the LFSO or versionnumber keys if necessary.