The E-mail Activity Will Not Send Messages Unless the "Sender Address" is a Valid Sender E-mail Address for the Login that the Workflow Server Service is Using.

November 28, 2011 | KB: 1012838
Workflow Suite

Summary

The E-mail activity (and the e-mail portions of the Routing activities) will not send messages unless the "Sender Address" is a valid sender e-mail address for the login that the Workflow Server service is using.

Cause

This limitation is due to your e-mail client's safeguards against spoofed e-mail addresses. For example, when using Microsoft Exchange, you will receive the following error in this situation: "Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender."

Resolution

To avoid this problem, ensure that the "Sender Address" specified in the Advanced E-mail Settings and the E-mail Server Properties is a valid e-mail address for the user the Workflow Service is running as or for the username and password you provided the e-mail server properties (if you chose not to use default authentication).