An "Error 500 - internal server error" Error Message Displays When Logging In With The Laserfiche Mobile iPhone App.

August 8, 2011 | KB: 1012823
Laserfiche App 8.2

Summary

When using the Laserfiche Mobile iPhone App to log in to Laserfiche Web Access, you may receive the following error message:

    Could not connect to Laserfiche Web Access:
    Error 500 - internal server error

The Laserfiche Web Access URL is accessible when using the iPhone's web browser.

Cause

This issue can occur when the IIS application pool for your Laserfiche Web Access site is running in Classic Mode. By default, the Web Access application pool should be running in Integrated Mode.

Resolution

Set the appropriate Web Access application pool to run in Integrated Mode.

To modify an application pool's Managed Pipeline Mode setting

  1. Open the Internet Information Services (IIS) Manager.
  2. Under your Web Access server, select the Application Pools item.
  3. In the list of available application pools, double-click the one hosting your Web Access site. A default Web Access installation runs in the WebAccess8AppPool application pool.
  4. In the Edit Application Pool dialog box, set the Managed pipeline mode option to Integrated.