A Laserfiche 8 Custom Quick Search Is Not Available In the Laserfiche Client After You Import the CustomQuickSearch Trustee Attribute.

August 8, 2011 | KB: 1012822
Laserfiche 8, Laserfiche 9

Summary

When you import a set of custom quick search trustee attributes, the newly imported custom quick searches may not be available in the Laserfiche Client 8.

Cause

The Laserfiche Client loads the [SETTINGS]CustomQuickSearch trustee attributes sequentially from [SETTINGS]CustomQuickSearch1, [SETTINGS]CustomQuickSearch2, [SETTINGS]CustomQuickSearch3, etc. until it reaches a break in the counter. Any subsequent CustomQuickSearch trustee attribute values will not displayed in the Laserfiche Client. For example, if user A currently only has a [SETTINGS]CustomQuickSearch1 attribute, and you export User B's [SETTINGS]CustomQuickSearch3 attribute and import that attribute into User A's trustee attributes, the imported custom quick search will not be available in the Laserfiche Client.

Workaround

Rename the appropriate CustomQuickSearch attributes so that there is an unbroken sequence of CustomQuickSearch attributes.