A "The page cannot be found" Error Occurs When Printing To PDF With WebLink 8.

June 13, 2011 | KB: 1012804
WebLink 8

Summary

When you click the Print PDF button in the WebLink document viewer, you may receive an HTTP 404 error. Different browsers may display variations of the following error messages:

    The page cannot be found.

    The webpage cannot be found.

    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

Cause

This issue can occur if the WebLink 8 virtual directory is missing a custom handler mapping for .pdf extensions. The WebLink 8 installation process will create the necessary handler mapping for the default WebLink 8 virtual directory; however, you must manually create the mapping if you decide to create a new virtual directory.

Resolution

Use the Internet Information Services (IIS) Manager to create a handler mapping.

IIS 7 on Windows Server 2008

  1. Click Start, point to Administrative Tools, and click Internet Information Services (IIS) Manager.
  2. Expand the Default Web Site and select the appropriate WebLink 8 virtual directory.
  3. In the Features View, double-click Handler Mappings.
  4. In the Actions pane, click on Add Script Map....
  5. In the Add Script Map dialog box, in the Request path text box, type:
  6. *.pdf

  7. In the Executable text box, specify:
  8. C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll

  9. In the Name text box, specify:
  10. WebLinkPdfHandler

  11. Click OK to close the Add Script Map dialog box and save your changes.
  12. Click Yes if you are prompted to confirm your action.