A "Permission Denied." Error Message Occurs On the Browse Laserfiche Dialog Box In Agenda Manager 8 When Logging In To A Laserfiche 8.2 Repository.

April 18, 2012 | KB: 1012780
Agenda Manager 8

Summary

When using the Agenda Manager 8 Web site to add an attachment to an agenda item, you may receive a "Permission denied" error message when you attempt to log in to a Laserfiche 8.2 repository to browse for an item.

Cause

Agenda Manager 8.0.x relies on LFSO7 for communication with the Laserfiche Server. In certain situations, Laserfiche Server 8.2 may expect an LFSO7 connection to make use of the Laserfiche Firewall Compatibility Component (FCC). While you can configure Agenda Manager Server to connect to your Laserfiche Server over the FCC port through the Agenda Manager Configuration Wizard, the Browse Laserfiche pop-up dialog box does not automatically retrieve the FCC port.

Workaround

Manually edit SelectRepository.asp and hardcode the Laserfiche server value.

  1. Browse to the ASP subfolder in your Agenda Manager Server installation folder. By default, the path is "C:\Program Files\Laserfiche\Agenda Manager\Server\ASP."
  2. Create a backup copy of SelectRepository.asp.
  3. Using a text editor, open SelectRepository.asp.
  4. At the top of the file, locate this line:
  5. this.serverName = serverName;

  6. Modify the line so that it is:
  7. this.serverName = 'yourLfServerIP:1888::yourFCCPort';

    Replace yourLfServerIP with the IP address of your Laserfiche server IP and replace yourFCCPort with the appropriate port in your FCC Server configuration file. By default, port is 2040.

  8. Save your changes to SelectRepository.asp.