Summary
When using the Agenda Manager 8 Web site to add an attachment to an agenda item, you may receive a "Permission denied" error message when you attempt to log in to a Laserfiche 8.2 repository to browse for an item.
Cause
Agenda Manager 8.0.x relies on LFSO7 for communication with the Laserfiche Server. In certain situations, Laserfiche Server 8.2 may expect an LFSO7 connection to make use of the Laserfiche Firewall Compatibility Component (FCC). While you can configure Agenda Manager Server to connect to your Laserfiche Server over the FCC port through the Agenda Manager Configuration Wizard, the Browse Laserfiche pop-up dialog box does not automatically retrieve the FCC port.
Workaround
Manually edit SelectRepository.asp and hardcode the Laserfiche server value.
this.serverName = serverName;
this.serverName = 'yourLfServerIP:1888::yourFCCPort';
Replace yourLfServerIP with the IP address of your Laserfiche server IP and replace yourFCCPort with the appropriate port in your FCC Server configuration file. By default, port is 2040.