Summary
After performing an upgrade from Laserfiche Avante 8.1 to Laserfiche Avante 8.2, the named user list may be missing from your Laserfiche Server. If you attempt to connect to the repository, you may receive the following error message:
The Maximum number of sessions that this server instance is licensed for has been reached. [9030]
If you are upgrading from Laserfiche Rio 8.1 to Laserfiche Rio 8.2, the main named user list will be upgraded intact, but the list of Laserfiche named users for each server may be lost.
Laserfiche Rio installations that do not use Laserfiche named users, and Laserfiche Servers that do not use named users, are unaffected by this issue.
Cause
The entire list of named users for Laserfiche Avante, and the list of Laserfiche named users (but not domain named users) for Laserfiche Rio, is stored in the Laserfiche Server installation directory. The Laserfiche 8.1 uninstallation process, which is a part of the upgrade, erroneously removes that file during the upgrade process. Since most Laserfiche Rio named users are stored in the Rio licensing database, those users are unaffected. This issue only affected Laserfiche Server 8.2 installations downloaded before January 4, 2011, with a setup.exe file of version 8.2.0.605 or lower.
Resolution
This issue has been resolved in Laserfiche Server installations released after January 4, 2011. The issue will not be encountered when using Laserfiche Server installation packages with a setup.exe of version 8.2.0.606 or higher. If you have not yet performed the upgrade, please download the most recent version of the Laserfiche Server installation.
If you have already performed the upgrade with an version of the installation package for Laserfiche Server 8.2 that was released before January 4, 2011, you will need to manually restore you list of named users. See Workaround 2 for more information.
Workaround 1
If you have not yet upgraded from Laserfiche 8.1 to Laserfiche 8.2, you can manually back up the file that contains your named user licenses. This must be done prior to performing the upgrade. (If you have already performed your upgrade, see Workaround 2.)
Workaround 2
If you have already upgraded the Laserfiche Server to 8.2, you will need to manually restore your list of named users. If you are using Laserfiche Avante, you will need to manually restore your entire named user list; if you are using Laserfiche Rio, you will need to manually restore only Laserfiche named users allocated to the Laserfiche Server you upgraded.
See Administering Named User Connections with Laserfiche Avante and Administering Named User Connections with Laserfiche Rio for more information.
Tip: You can select multiple existing users and add them to the Named User list at one time. To do so, in the Laserfiche Administration Console select the Laserfiche Users or Windows Account users you want to add, right-click, point to All Tasks, and select Add to Named Users.
Note: You do not need to re-add Windows domain or LDAP directory named users to Laserfiche Rio installation. These types of named users are retained by the Laserfiche Rio upgrade.