Summary
When attempting to e-mail a document in Web Access 8, as either a URL link, file, or zip, the following error is displayed after a period of inactivity:
HttpException (0x80004005): Request timed out
Cause
In most cases, this error only occurs when attempting to e-mail large documents, in which case Web Access takes longer to process the request than the software's default timeout limit will allow.
Resolution 1
Significantly increase the default timeout limit so that Web Access will not timeout when processing the request.
Note: This resolution does not speed up the amount of time it takes to send an e-mail.
Important: The steps below require you to edit Web Access' web.config file, which, if edited incorrectly, may cause Web Access to stop running. As a precaution, backup the original copy of this file before making any changes. If your change causes problems, replace the edited file with the original.
To increase the timeout limit:
<location path="Dialogs/SendEmail.aspx">
<system.web>
<httpRuntime executionTimeout="7200"/>
</system.web>
</location>
Note: This code sets the timeout limit to 120 minutes (7,200 seconds). You can alter this number if necessary.
Resolution 2
If you only need to e-mail a URL link to the document, and not a copy of it, manually build the URL and e-mail it.
To manually build and send a document URL:
Note: This URL will open a Laserfiche imaged document in Web Access' Document Viewer or prompt the user to download an electronic file. For more information on manually building Web Access URLs, see a white paper titled URL Linking in Web Access 8.1 (a log in is required to download the paper).