A "Connection Has Been Disabled" Error Occurs When Using Quick Fields 8's Lookup Process.

July 26, 2010 | KB: 1012623
Quick Fields 8

Summary

When attempting to run a session containing a Lookup process, the following error occurs:

    Connection has been disabled.[Method=ExecuteFirstResult]

Cause

This error occurs when the Lookup process is configured to interact with an Oracle database using an Oracle ODBC 10.0.2.1 driver. Due to an issue with this driver, Lookup, which runs as an external executable, cannot interact with the database.

Tip: To view a list of ODBC drivers installed on the Quick Fields machine, open the ODBC Data Source Administrator dialog box and view the Drivers tab. To open this dialog box in Windows XP, select Administrative Tools in Control Panel's Classic View, and then double-click Data Source (ODBC). In Windows 7, type "Data Sources (ODBC)" into the Start menu's Search box and select the first search result.

Resolution 1

Use Field Lookup instead of the Lookup process. This process will not return the error, because Field Lookup does not run as an external executable.

Note: If you want Field Lookup to run when the document is processed, as the Lookup process does, ensure you choose When the document is processed when configuring Field Lookup.

Resolution 2

Upgrade your Oracle ODBC driver to 10.0.2.4, 11.1.0.6, 11.1.0.7, or higher. For more information, see Oracle's website.