Summary
When activating Laserfiche Server 8.1.x on a clean computer, the Activation Tool may display the following error message:
Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.
Could not load file or assembly 'System.Runtime.Serialization, Version 3.0.0.0, Culture=neutral, PublicKey Token=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
Cause
The Laserfiche product activation process relies on Microsoft .NET Framework technology. However, the Laserfiche Server installation does not contain a prerequisite check for at least .NET Framework 3.0. This issue can occur if Microsoft .NET Framework 3.0 or later is not installed on the computer.
Resolution
Install Microsoft .NET Framework 3.0 or later before re-running the activation tool. Almost all Laserfiche 8 client applications include .NET Framework as part of the installation process. You can also choose to manually install .NET Framework as redistributable .NET Framework installation packages are available from microsoft.com.
See the following Microsoft download page for .NET Framework 3.5 Service Pack 1:
http://www.microsoft.com/downloads/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&DisplayLang=en
Note: Windows Server 2008 R2 includes .NET Framework 3.5 Service Pack 1 and you cannot manually install it from the standalone installation packages. Enable the .NET Framework 3.5.1 Features option from the Add Features Wizard in the Server Manager.