The Laserfiche Server 8 May Fail to Start Due to a "WMI provider module registration failed" Error (Error Code -2147217390).

April 19, 2010 | KB: 1012582
Laserfiche Standard Server 8

Summary

When attempting to start the Laserfiche Server 8, it may start then immediately stop, and the following error may be reported to the Windows Event Viewer:

    WMI provider module registration failed. Error -2147217390: %%-2147217390

Note: Ensure the error code you receive is -2147217390 before completing the steps below. If you receive the same error message, but a different code, the steps below may not apply. If you receive error code -2147217394, see KB 1012576.

Cause

The appropriate Windows services are not running.

Resolution

Complete the following steps:

  1. Start the Windows Management Instrumentation Driver Extension service (this service only needs to be started if you encounter error code 2147217390, not in all Laserfiche installations). On Windows XP, select Start, select Run, type "services.msc", and select OK. In the Services window, right-click the service named Windows Management Instrumentation Driver Extension and select Start.
  2. Ensure the Windows Management Instrumentation service is running (this service should always be running, for all Laserfiche installations). In the Services window, right-click the service named Windows Management Instrumentation. If the Start option is available to select, do so. If it is not, the service is already running.
  3. Attempt to start the Laserfiche Server 8. In the Services window, right-click the service named Laserfiche Server 8.x (where x matches the version of the Laserfiche Server you have installed) and select Start.