Summary
When you attempt to perform a search and the Laserfiche Full-Text Search and Indexing Service (LFFTS) is in the middle of indexing a large number of small documents, you may receive the following error message:
The search engine encountered an internal error. Please check the search engine error log for more details. (9132)
Cause
When indexing a large number of small documents, Laserfiche did not efficiently lock and unlock the idx files. This could prevent search requests from being able to access the idx files and cause the above error message.
Resolution
There is a hotfix available for Laserfiche Server 8.1.1. The fix includes updated versions of the following files:
Important:This hotfix is for Laserfiche Server 8.1.1 only. Please make sure you are on 8.1.1 before applying it.
To update Laserfiche Server 8.1.1
More Information
As a further precaution against searches timing out from being unable to access the idx files, you can increase the HKEY_LOCAL_MACHINE\SOFTWARE\Laserfiche\LFFTS\Database\databaseName\SearchWaitTime registry value to 20 seconds.
To increase the search timeout limit
regedit
SearchWaitTime