A "Search engine encountered an internal error." Error Message May Occur When Performing Searches During the Indexing Process.

November 23, 2009 | KB: 1012385
Laserfiche Server - Team (MSDE) 8.1, Laserfiche Server - United (MS SQL) 8.1, Laserfiche Server - United (Oracle) 8.1

Summary

When you attempt to perform a search and the Laserfiche Full-Text Search and Indexing Service (LFFTS) is in the middle of indexing a large number of small documents, you may receive the following error message:

    The search engine encountered an internal error. Please check the search engine error log for more details. (9132)

Cause

When indexing a large number of small documents, Laserfiche did not efficiently lock and unlock the idx files. This could prevent search requests from being able to access the idx files and cause the above error message.

Resolution

There is a hotfix available for Laserfiche Server 8.1.1. The fix includes updated versions of the following files:

  • FTSKernel.dll (version 8.1.1.611)
  • LFFTSUtility.dll (version 8.1.1.611)
  • LfFTS.exe (version 8.1.1.611)
  • QRcmd.exe (version 8.1.1.611)

Important:This hotfix is for Laserfiche Server 8.1.1 only. Please make sure you are on 8.1.1 before applying it.

To update Laserfiche Server 8.1.1

  1. Stop the Laserfiche Full-Text Indexing and Search service.
  2. Click one of the following links to download a zip file containing the hotfix files.
  3. Hotfix_SCR53968_win32.zip

    Hotfix_SCR53968_x64.zip

  4. Replace your existing versions of LfFTS.exe, FTSKernel.dll, LFFTSUtility.dll, and QRcmd.exe in your Laserfiche Server installation folder with the updated versions included in the zip file. By default, the Laserfiche Server is installed at "C:\Program Files\Laserfiche\Server."
  5. Start the Laserfiche Full-Text Indexing and Search Service.

More Information

As a further precaution against searches timing out from being unable to access the idx files, you can increase the HKEY_LOCAL_MACHINE\SOFTWARE\Laserfiche\LFFTS\Database\databaseName\SearchWaitTime registry value to 20 seconds.

To increase the search timeout limit

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor:
  3. regedit

  4. Expand HKEY_LOCAL_MACHINE.
  5. Expand SOFTWARE.
  6. Expand Laserfiche.
  7. Expand LFFTS.
  8. Expand DataBase.
  9. Select the key for named after your repository.
  10. If the SearchWaitTime value does not exist:
    1. From the Edit menu, point to New and click String Value.
    2. Name the new string value:
    3. SearchWaitTime

    4. Double-click the newly created value and set it to 20.
  11. Restart the Laserfiche Full-Text Indexing and Search Service.