A “MMC could not create the snap-in” Error Occurs When Attempting to Open a Laserfiche MMC Snap-In.

September 7, 2010 | KB: 1012366
Laserfiche

Summary

When attempting to open a Laserfiche Microsoft Management Console (MMC) snap-in, such as the Laserfiche Administration Console or the Workflow Administration Console, the following error is displayed:

    MMC could not create the snap-in. The snap-in might not have been installed correctly.

Cause

In most cases, this issue only occurs on machines running localized (i.e., non-English) versions of Windows XP Service Pack 3. The problem occurs due a Microsoft issue involving incorrect .dll files.

Resolution

Review Microsoft KB 957502 and apply the corresponding hotfix.