A "The binding at system.serviceModel/bindings/netNamedPipeBinding does not have a configured binding named 'AgentBinding'" Error Occurs When Connecting to the Quick Fields 8 Agent Service.

September 21, 2009 | KB: 1012339
Quick Fields Agent 8.0.1

Summary

When using the Quick Fields Agent Administration Console to connect to the Quick Fields Agent service, you may receive the following error message:

    The binding at system.serviceModel/bindings/netNamedPipeBinding does not have a configured binding named 'AgentBinding'. This is an invalid value for bindingConfiguration. (C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Laserfiche.QuickFields.Agent.Console.dll.config line 5)

Cause

This issue can occur if Microsoft .NET Framework 3.5 Service Pack 1 (SP1) is not installed on the computer with the Laserfiche Quick Fields Administration Console. The Quick Fields Agent installation will not install .NET Framework 3.5 Service Pack 1 if it detects the existence of .NET Framework 3.5.

Resolution 1

Install Microsoft .NET Framework 3.5 Service Pack 1. See the following Microsoft Download page for .NET Framework 3.5 Service Pack 1.

http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en

Resolution 2

There is a hotfix available for Quick Fields 8.0.1. The fix is an updated version of Laserfiche.QuickFields.Agent.exe (version 8.0.1.220).

  1. Stop the Laserfiche Quick Fields Agent service.
  2. Click the following link to download a zip file containing the hotfix.
  3. Hotfix_SCR51806.zip

  4. Replace your existing version of the file with the updated version included in the zip file. By default, Laserfiche.QuickFields.Agent.exe is located at "C:\Program Files\Laserfiche\Quick Fields 8.0"
  5. Start the Laserfiche Quick Fields Agent service.
  6. Copy Laserfiche.QuickFields.Agent.Console.dll.config to "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727." By default, this file is installed at "C:\Program Files\Laserfiche\Quick Fields 8.0."