A "There was no endpoint listening at https://activation.laserfiche.com/IActivationService.svc that could accept the message." Error Occurs During the Activation Process.

September 4, 2009 | KB: 1012333
Quick Fields 8, Laserfiche Rio 8, Laserfiche Server - Avante 8

Summary

When going through the product activation process, you may receive the following error message:

    "There was no endpoint listening at https://activation.laserfiche.com/IActivationService.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

Cause

This issue can occur in certain situations when using the Windows default proxy settings for HTTPS.

Workaround

Manually edit a configuration file to ignore the default Windows proxy settings and to directly access the activation service without going through a proxy server. For Quick Fields 8, edit the Laserfiche.QuickFields.exe.config file. For Laserfiche Server 8, edit the ActivationTool.exe.config file.

  1. Using a text editor, do one of the following:
    • Open the Laserfiche.QuickFields.exe.config file located in your Quick Fields installation folder. By default, Quick Fields is installed at "C:\Program Files\Laserfiche\Quick Fields 8.0."
    • Open the ActivationTool.exe.config file located in your Laserfiche Server 8 installation folder. By default, Laserfiche Server 8 is installed at "C:\Program Files\Laserfiche\Server."
  2. In the <wsHttpBinding> section, locate the <binding> element's useDefaultWebProxy attribute and set it to false.
  3. Save your changes to the configuration file.