An "[HRESULT:0x80010105 (RPC_E_SERVERFAULT)]" Error Occurs When Repeatedly Closing and Reopening Laserfiche Scanning.

July 20, 2009 | KB: 1012298
Laserfiche 8, Scanning 8

Summary

When repeatedly closing and reopening Laserfiche Scanning, you may receive the following error message:

    [HRESULT:0x80010105 (RPC_E_SERVERFAULT)]

The error does not occur if after closing Laserfiche Scanning, you wait at least 20 seconds before reopening Laserfiche Scanning.

Cause

Laserfiche Scanning may still be in the process of unloading the scanner drivers when the new instance of Scanning loads.

Resolution 1

This issue is resolved in Laserfiche 8.1.1 and later. Please upgrade to the latest version of Laserfiche.

Resolution 2

There is a hotfix available for Laserfiche Scanning 8.1. The fix is an updated version of ScanConnect.exe (version 8.1.0.440).

To update Laserfiche Scanning 8.1

  1. Close any open instances of Laserfiche Scanning 8.1.
  2. Click the following link to download a zip file containing the hotfix:
  3. Hotfix_ScanConnect_8.1.0.440.zip

  4. Replace your existing version of ScanConnect.exe located at "C:\Program Files\Common Files\Laserfiche\Batch Processor" with the updated version included in the zip file.