A "General database error. [9008]" Error Occurs When Performing Certain Date Searches When Using Certain Non-English Versions of Microsoft SQL Server.

June 12, 2009 | KB: 1012254
Laserfiche Server - Team (MSDE) 8.1, Laserfiche Server - United (MS SQL) 8.1

Summary

When performing a date search where the day value is greater than 12, you may receive the following error message:

    General database error. [9008]

Cause

This issue can occur when using certain non-English versions of Microsoft SQL Server. When coupled with setting the computer's regional settings to use a short date format of yyyy-mm-dd, Laserfiche may incorrectly format the SQL search query.

Resolution 1

This issue is resolved in Laserfiche 8.1.1 and later. Please upgrade to the latest version of Laserfiche.

Resolution 2

There is a hotfix available for Laserfiche Server 8.1. The fix is an updated version of cr.dll (version 8.1.0.455).

To update Laserfiche Server 8.1

  1. Stop the Laserfiche Server 8 service.
  2. Click one of the following link to download either the 32-bit or the 64-bit version of the hotfix.
  3. Hotfix_SCR48772_win32.zip

    Hotfix_SCR48772_x64.zip

  4. Replace your existing version of cr.dll with the updated version included in the zip file. By default, the file is in "C:\Program Files\Laserfiche\Server."
  5. Start the Laserfiche Server 8 service.

Related Links

Cr.dll (version 8.1.0.455) also includes a hotfix for a separate issue. Please see the following Laserfiche Knowledge Base article for more information.

1012264 The List of Linked Documents May Not Exclude Documents Assigned a Security Tag.