An "Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))" Error Occurs When Opening Documents in WebLink.

June 8, 2009 | KB: 1012243
WebLink 8

Summary

When you open a document through WebLink 8, you may receive the following error message:

    Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Cause

The user account used to authenticate to IIS may not have sufficient Windows permissions to one or more of the following Windows folders:

  • The WebLink temporary image cache and PDF cache folders: These folder locations is customizable through the WebLink 8 Administrator's Utility. By default, they are located at "C:\Program Files\Laserfiche\WebLink 8\tempDirectory" and "C:\Program Files\Laserfiche\WebLink 8\tempPDFDirectory."
  • The WebLink "Web Files" folder: This folder is located in your WebLink 8 installation folder. By default, it is located at "C:\Program Files\Laserfiche\WebLink 8\Web Files."
  • The Windows TEMP system environment variable: By default, the variable is usually configured to "C:\Windows\Temp."
  • The WebLink log files folder: WebLink may write logging information to the "C:\Temp\WebLink Log" folder.

Resolution

If WebLink is configured for anonymous access, make sure that the specified Windows user account can read and write to the specified folders. If WebLink is configured for Windows authentication, make sure that all necessary domain users can access the folders.

Related Links

1012586 Modifying the WebLink 8 Log File Path.